Problems with iPad playback - not scrolling down

Hi there,

Has anyone seen it where a published course (through Moodle) when viewed on an iPad, won’t scroll down past the first displayed part of the page, i.e with a scrolling page ahead of you, you try to move down but it won’t go any further?

It could just be the iPad we were testing on is old or has some other issue, but wanted to see if it was a known symptom of something before we start to investigate fruitlessly…


Here’s an example. No scroll bar, and if you push up there is just an area of white at the bottom of the page.

Is Moodle wrapping the content in an iFrame? iOS/Safari has always been a bit weird about handling scrolling content in iFrames. (It was a long-running issue in Adapt, though something I think has been fixed recently.)

I suppose it is yes - i’ve tried all the Publish settings like iframe fix and in moodle having it in a window works but not when you have it in a New Window, so i’ve tried to publish with all combinations of options.

The ipad works fine with a course I published last year out of Evolve and into Moodle in the same way, but not with the same course published now, so i guess at some point in Evolve the code has changed and support has dropped. My iPad is on 9.3.5 and my boss’ is 9.3.2. Other content from other sites and courses still works on them so it’s a shame that Evolve doesn’t support this any more :frowning: