Problem with MCQ Question Banks

Ok so I have put together an 8-page assessment made up of MCQ questions using the question bank extension as well as other components like drag and drop. So about 40 MCQ questions and about 10 other various types.

The questions from the question banks all populate just as they should. No issues getting them to work. What I AM having an issue with though is that if a user completes some of the questions and then leaves the course, when they return, all of their progress from the question banks is lost. The other components retain their completed status, but not so for question bank questions.

My guess here is that these questions are all refreshed from the bank when they come back. So they might get entirely different questions in a different order.

Am I missing something? I don’t want my users to have to essentially start over if they have to leave the exam and return. I’m OK with them getting different questions in a different order when they retake the exam. But I would prefer that they get the same questions if they are simply returning to the exam.

I suspect if I didn’t use the question banks this wouldn’t be an issue.

We use question banks (not as extensively as you). When I QA our courses I’ve left mid-way, returned, and whether I resume the course or choose to start over, I can see that the learner’s progress was preserved. I can see the same question from a bank, and the chosen response and the subsequent feedback. I wonder if bookmarking has anything to do with your situation?

Thank you for the suggestion on bookmarking. I had bookmarking enabled, but I tried creating a version that did not use bookmarking and I am still seeing the same result. It was definitely worth a shot. I have even used a different LMS but that also made no difference.

So, still struggling with this, if anyone has additional suggestions I’m willing to give it a try.

Hi @b.allen - enabling the local storage extension on the course might resolve this for you.

On first try, Local Storage does indeed appear to resolve the issue. I’ll need to test it a little more, but it looks promising. Thank you for the suggestion :smile:


1 Like