Spaces in French courses

In French, we need to insert a space before every double sign (:;?!). These additional spaces must be non-breaking spaces to prevent the sign from appearing on the next line. I’ve been using a Unicode character (ctrl+shift+u)a0 to create these spaces, and it works well until I open the text in the editor or make changes to the text appearance in the theme. At that point, the non-breaking space seems to be replaced by a standard space. While it’s not a significant issue for this course since I’ve double-checked everything, it poses a real challenge for course creation in French. Is there a workaround?

I appreciate your assistance with these matters.

Hi Catherine-Helen :wink:

Having done a bit of research I’m actually a bit surprised this isn’t something you can do automatically via HTML/CSS these days…

However, you can set it manually where needed in Evolve. This is how it’s done:
screenshot of a no wrap class being applied to text in evolve

Hi Matt,
Many thanks for your help!
I’ve also found a way to fix the problem: Evolve takes into account the narrow non-breaking space Unicode character U+202F, which means that I can copy and paste content already formatted instead of setting it manually.